Back to overview
Resolved
API Service latency
Jun 7, 2025 at 3:17pm UTC
Affected services
api.natemarcellus.com
Resolved
Jun 7, 2025 at 3:37pm UTC
We have identified the issue with the API latency and have resolved all issues.
Affected services
Created
Jun 7, 2025 at 3:17pm UTC
API Service is currently experiencing latency and having issues returning resources to the webpage.
Affected services