Back to overview
Resolved
Upgrading API Service and integration
Nov 10, 2025 at 5:12pm UTC
Affected services
api.natemarcellus.com
files.natemarcellus.com
support.natemarcellus.com
careers.natemarcellus.com
Resolved
Nov 14, 2025 at 2:43pm UTC
Update applied
Affected services
Updated
Nov 12, 2025 at 6:26am UTC
File service and API Going down for incoming missionchiefbotx and launcher integration.
Affected services
Created
Nov 10, 2025 at 5:12pm UTC
API Will be going through constant restarts along with all of our other services.
Affected services